You are not logged in.

#1 2007-09-12 18:27:06

regnskog
Member
From: Stockholm, Sweden
Registered: 2006-08-06
Posts: 17

Making gnash work as firefox plugin?

This might be stupid but I can't get it to work and I've found no guides anywhere on the internet. Should the plugin be installed automatically when i install the gnash-package or what do I need to do?

Offline

#2 2007-09-12 20:37:32

N30N
Member
Registered: 2007-04-08
Posts: 273

Re: Making gnash work as firefox plugin?

regnskog wrote:

Should the plugin be installed automatically when i install the gnash-package or what do I need to do?

The gnash-gtk package has the plugin for firefox.

Offline

#3 2008-09-28 21:01:12

tony5429
Member
Registered: 2006-03-28
Posts: 909
Website

Re: Making gnash work as firefox plugin?

Was this ever resolved? I am having the same problem. I just installed gnash-gtk and it is not working in firefox: http://wikicode.frihost.net/youtube_gnash.png


Yellowcot: A free, lightweight, open-source, cross-platform, Qt-based multimedia flash card simulator.

Offline

#4 2008-10-04 19:40:07

sashko
Member
From: Rivne, Ukraine
Registered: 2008-10-02
Posts: 7
Website

Re: Making gnash work as firefox plugin?

tony5429 wrote:

Was this ever resolved? I am having the same problem. I just installed gnash-gtk and it is not working in firefox: http://wikicode.frihost.net/youtube_gnash.png

I have the same problem. sad

Offline

#5 2008-10-18 19:38:02

CjK
Member
Registered: 2008-10-17
Posts: 12

Re: Making gnash work as firefox plugin?

The current gnash-gtk package is broken. Is does not take into account the new boost-lib dependencym, see here:

http://bugs.archlinux.org/task/11584?st … &closedto=

I guess this will be fixed eventually, but for me, there is still another problem: My firefox plugin directory is /usr/lib/xulrunner-1.9.0.3/plugins but the gnash-package thinks it must be under /usr/lib/mozilla/plugins. So I created a symlink from the first to the latter directory.

But because of the boost-lib issue, I had to create my own package-build from a recent gnash-dev snapshot. Now, for the first time I have gnash working and can watch you-tube videos under x64.

If there is enough interest, I could adopt the current orphan gnash-cvs package in "unsupported" to help out until the other devs have catched up.

Let me know what you think.

Claus

Last edited by CjK (2008-11-08 19:51:09)

Offline

#6 2008-10-18 21:09:41

Riklaunim
Member
Registered: 2005-04-09
Posts: 106
Website

Re: Making gnash work as firefox plugin?

You can also use extra/swfdec-mozilla plugin.

Offline

#7 2008-10-18 21:25:06

CjK
Member
Registered: 2008-10-17
Posts: 12

Re: Making gnash work as firefox plugin?

Riklaunim wrote:

You can also use extra/swfdec-mozilla plugin.

Swfdec just never worked for me (no picture in videos) so I gave up on it.

But right, one should use whatever works for her/him.

Gnash is making quick progress recently, so I'll stay with it for the time being.

Claus

Offline

#8 2008-10-29 21:17:47

richardmurri
Member
Registered: 2008-10-29
Posts: 39

Re: Making gnash work as firefox plugin?

CjK wrote:

If there is enough interest, I could adopt the current orphan gnash-cvs package in "unsupported" to help out until the other devs have catched up.

I'd be interested.

Offline

#9 2008-10-30 21:55:59

mykey
Member
From: out of the blue
Registered: 2007-03-02
Posts: 110

Re: Making gnash work as firefox plugin?

CjK wrote:

If there is enough interest, I could adopt the current orphan gnash-cvs package in "unsupported" to help out until the other devs have catched up.
Let me know what you think.

yeah - I'd be interested too - I can't get it to build - why don't you supply the PKGBUILD for the time being

Offline

#10 2008-10-30 22:20:16

CjK
Member
Registered: 2008-10-17
Posts: 12

Re: Making gnash work as firefox plugin?

OK, here is the PKGBUILD that currently works for me, using a recent snapshot from gnashdev.

Two issues remain:

1. Current versioning needs to be improved to enable updates (shouldn't be too difficult, I just didn't care enough for now)

2. Not sure what plugin-dir defaults to on other systems. Mine is "/usr/lib/xulrunner-1.9.0.3/plugins/" but I created a symlink from /usr/lib/mozilla/plugins to the former to make it more generic. No idea whether this is the correct place. Adjust this parameter, if your Firefox-plugin dir is somewhere else. I'm using Firefox 3.0.3 from AUR.

This package provides both the standalone gnash-player *and* the plugin. So it replaces gnash-common and gnash-gtk.

Let me know what to improve or whether it works for you. I can then upload it to AUR.


# Contributor : Claus Klingberg <cjk@pobox.com>

pkgname=gnash
pkgver=trunk
pkgrel=10051
pkgdesc="A GNU Flash movie player."
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/gnash/"
license=("GPL3")
depends=('fontconfig' 'libxml2' 'curl' 'libtool>=2.2-2' 'ffmpeg>=20080625' 'boost>=1.34.1-2' 'libxi' 'libdca' 'glib2')
makedepends=('pkgconfig' 'diffutils' 'agg' 'gtk2')
# source=(http://ftp.gnu.org/gnu/gnash/${pkgver}/gnash-${pkgver}.tar.bz2)
source=(http://www.gnashdev.org/dev_snapshots/gnash-${pkgver}-${pkgrel}.tar.tgz)
# FIXME:
# md5sums=('5033ef2602ea1234a9ccb73000a0dedb')
options=('!libtool' '!emptydirs')
provides=('gnash')
replaces=('gnash')

build() {
 cd $startdir/src/gnash-$pkgver

 ./configure --prefix=/usr \
     --sysconfdir=/etc \
     --disable-kparts \
     --with-npapi-plugindir=/usr/lib/mozilla/plugins \
     --enable-gui=GTK \
     --enable-z \
     --enable-jpeg \
     --enable-renderer=agg \
     --enable-media=ffmpeg \
     --enable-write \
     --enable-mp3 \
     --disable-cygnal \
     --disable-static \
     --with-ffmpeg-incl=/usr/include || return 1

 make || return 1
 make DESTDIR=$startdir/pkg install install-plugin

}

Offline

#11 2008-10-30 23:04:48

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,931

Re: Making gnash work as firefox plugin?

Welcome to the forums CjK.

You're PKGBUILD works here even with a FFmpeg that's around eight hours old. Nice. I have a question: is the quality poor for you?

Offline

#12 2008-10-31 09:34:35

CjK
Member
Registered: 2008-10-17
Posts: 12

Re: Making gnash work as firefox plugin?

skottish wrote:

You're PKGBUILD works here even with a FFmpeg that's around eight hours old. Nice. I have a question: is the quality poor for you?

Nice to hear it works for you.

Can't really judge quality by now; Haven't watched enough high-quality movies recently. Compared to my S.O's Ubuntu + AdobeFlash combination stands up well.

For now, I guess we have to be gratefull if most movies play at all (and don't crash) :-}

Anyway - I refused to install a bunch of otherwise needless lib32 overhead to make ignorant Adobe's Flash happy on x64.

Offline

#13 2008-10-31 17:38:33

richardmurri
Member
Registered: 2008-10-29
Posts: 39

Re: Making gnash work as firefox plugin?

Awesome, thanks.

Offline

#14 2008-11-01 15:13:06

mykey
Member
From: out of the blue
Registered: 2007-03-02
Posts: 110

Re: Making gnash work as firefox plugin?

Hei - thanks a bunch CjK - it works real nice over here too, hits the default plug-in dir and the naming seems ok since it reflects the naming of the coders - NICE

mykey

Offline

#15 2011-01-13 19:01:59

maximi89
Member
Registered: 2011-01-13
Posts: 1

Re: Making gnash work as firefox plugin?

you just need:

./configure  --enable-hwaccel=vaapi
make
make install-plugin
su -c "make install"

Offline

#16 2011-01-14 01:25:18

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,079

Re: Making gnash work as firefox plugin?

maximi89,

The thread is more than 2 years old. I am sure the op has moved on.

So I am going to close this thread, now that it has a possible solution from you and we don't want users to keep bumping an old thread.


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

Board footer

Powered by FluxBB