You are not logged in.

#1 2004-10-15 01:34:54

rayzorblayde
Member
Registered: 2004-01-04
Posts: 67

wireless (modprobe?) problem

first some system info

uname -r
2.6.8.1


modprobe --version
module-init-tools version 3.0


cat /etc/modprobe.conf
#
# /etc/modprobe.conf (for v2.6 kernels)
#

alias wlan0 ndiswrapper


ls /lib/modules/2.6.8.1/misc/
ndiswrapper.ko


modprobe -v ndiswrapper
FATAL: Module ndiswrapper not found.


Basically, I can't get my wireless to startup on boot and i think the last statement there is the problem.  I can get it to work manually by performing the following commands:

1. insmod /lib/modules/2.6.8.1/misc/ndiswrapper.ko
2. iwconfig wlan0 essid myessid
3. ifconfig wlan0 up
4. dhcpcd wlan0

and then it all works fine.  what i dont' understand is why insmod works, but modprobe doesn't, when the file is in the correct folder (/lib/modules/2.6.8.1/).  is there something i have to do to tell modprobe to refresh it's list or something?  any help is appreciated.  thanks!


ps. i did do many searches for this problem and found nothing, so if this has been asked already, i apologize.


loading.... please wait....

Offline

#2 2004-10-15 09:44:42

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: wireless (modprobe?) problem

not sure what can be the problem ...

but i would try to run as root depmod -a ... just do make sure

then i would try to find out, what dmesg says more about your kernel and details of maybe-errors


The impossible missions are the only ones which succeed.

Offline

#3 2004-10-15 14:58:24

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: wireless (modprobe?) problem

the problem is definately depmod:
to everyone out there, if new external modules are installed, you should usually run depmod -a in order to rebuild a list of modules that the kernel can see, if you do not do this your new modules might not be seen

in addition, make sure you have a proper ndiswrapper driver... if you are in need, you can check my repo below (currently I am not aware of any problems with the ndiswrapper packages, but if you come across any, let me know)  the ndiswrapper package comes with a script for rc.conf... /etc/conf.d/ndiswrapper for your wireless settings and simply add the ndiswrapper daemon in your rc.conf BEFORE network... this way you could add wlan0="dhcp" and INTERFACES="wlan0" to start on boot

Offline

#4 2004-10-17 13:37:39

rayzorblayde
Member
Registered: 2004-01-04
Posts: 67

Re: wireless (modprobe?) problem

cool, thanks everyone.

it works now... with the help from someone else's startup script in another thread, it's working just fine now.

smile


loading.... please wait....

Offline

Board footer

Powered by FluxBB