You are not logged in.

#1 2009-10-05 16:46:39

csergec
Member
Registered: 2009-09-29
Posts: 62

phpmyadmin update [SOLVED]

Hi

the new update phpmyadmin-3.2.2-3 installs the files  in:

/usr/share/webapps/

instead of

/srv/http/

Is it an error?
if not how to use it now?

Serge

Last edited by csergec (2009-10-07 21:00:35)

Offline

#2 2009-10-05 17:28:18

bluewind
Administrator
From: Austria
Registered: 2008-07-13
Posts: 165
Website

Re: phpmyadmin update [SOLVED]

No error. For an example check /etc/webapps/phpMyAdmin/apache.example.conf

You maybe also want to read the thread on the ML: http://mailman.archlinux.org/pipermail/ … 07800.html (it's long)


"Everything should be made as simple as possible, but not simpler."
-- Albert Einstein

Offline

#3 2009-10-05 19:09:18

csergec
Member
Registered: 2009-09-29
Posts: 62

Re: phpmyadmin update [SOLVED]

Thank you Bluewind for you quick answer

I 've read "partly" the thread.
I copied the file
/etc/webapps/phpMyAdmin/apache.example.conf
to
/etc/httpd/conf/extra/httpd-phpmyadmin.conf

I think I did well about the following:
add FollowSymlinks options
append directories to php.ini ????
open_basedir = /usr/share/webapps/:/etc/webapps
change web-alias to /usr/share/webapps/phpMyAdmin


How do you open phpmyadmin in a browser?

Offline

#4 2009-10-05 21:45:07

fukawi2
Forum Moderator
From: .vic.au
Registered: 2007-09-28
Posts: 5,280
Website

Re: phpmyadmin update [SOLVED]

Gargh, I missed this change... Time to subscribe to arch-general.

Offline

#5 2009-10-05 21:56:26

Ravenman
Member
Registered: 2009-07-03
Posts: 222

Re: phpmyadmin update [SOLVED]

bluewind wrote:

No error. For an example check /etc/webapps/phpMyAdmin/apache.example.conf

You maybe also want to read the thread on the ML: http://mailman.archlinux.org/pipermail/ … 07800.html (it's long)

I have this issue too: phpMyAdmin doesn't works after upgrading. yikes

My /etc/httpd/conf/extra/httpd-phpmyadmin.conf file:

Alias /phpmyadmin/ "/usr/share/webapps/phpMyAdmin/"
        <Directory "/usr/share/webapps/phpMyAdmin">
                AllowOverride All
                Options FollowSymlinks
                Order allow,deny
                Allow from all
        </Directory>

My open_basedir line into /etc/php/php.ini file:

open_basedir = /srv/http/:/home/:/tmp/:/usr/share/pear/:/srv/:/usr/share/webapps/:/etc/webapps

When I get try start the apache server doesn't works and into the /var/log/httpd/error_log file, shows this:

[Mon Oct 05 16:05:37 2009] [error] [client 192.168.1.11] File does not exist: /srv/http/phpMyAdmin
[Mon Oct 05 16:08:16 2009] [error] [client 192.168.1.11] File does not exist: /srv/http/phpMyAdmin

When I get try access the phpMyAdmin webpage, the browser shows one error 404. sad

What remains to be done? neutral

Offline

#6 2009-10-06 05:20:17

csergec
Member
Registered: 2009-09-29
Posts: 62

Re: phpmyadmin update [SOLVED]

Ravenman

I am a little bit luckier than you I get the 403 error

For this, you need to add in your httpd.conf file

 Include conf/extra/httpd-phpmyadmin.conf

You can add under this line :
Alias /phpmyadmin/  /usr/share/webapps/phpMyAdmin/

And you will get the 403 error if you are as lucky as me , if not it will work for you.
I spent hours to try to resolve this 403 error, checked the permissions and so on.
Without results.

Serge

Offline

#7 2009-10-06 16:03:39

julio
Member
From: São Carlos/SP, Brazil
Registered: 2009-06-10
Posts: 9
Website

Re: phpmyadmin update [SOLVED]

I have te same problem here...

I tried to copy
/etc/webapps/phpmyadmin/apache.example.conf
to
/etc/httpd/conf/extra/httpd-phpmyadmin.conf

And create a symbolic link of the new phpMyAdmin folder to /srv/http/phpMyAdmin

But I just see a blank page in my browser.


smile

Offline

#8 2009-10-06 18:25:07

Teoulas
Member
From: Athens, Greece
Registered: 2009-03-21
Posts: 70

Re: phpmyadmin update [SOLVED]

There's also a .htaccess file in the phpMyAdmin directory denying access to everyone. Depending on your apache config, you might have to comment out the deny directive or completely delete the file.

Offline

#9 2009-10-06 18:39:00

julio
Member
From: São Carlos/SP, Brazil
Registered: 2009-06-10
Posts: 9
Website

Re: phpmyadmin update [SOLVED]

I got my phpMyAdmin working... Well at least until somebody find a better solution.

I download the package from:
http://www.phpmyadmin.net/home_page/index.php

And extracted it in my public_html folder

Now I can access the phpMyAdmin at http://localhost/~julio/phpMyAdmin-3.2.2-all-languages/


smile

Offline

#10 2009-10-06 18:53:21

csergec
Member
Registered: 2009-09-29
Posts: 62

Re: phpmyadmin update [SOLVED]

Removing .htacces did not help.
Commenting the line like this:

 #deny from all

did not help neither

Still stuck with 403...

Offline

#11 2009-10-07 14:49:09

toffyrn
Member
Registered: 2008-10-07
Posts: 221

Re: phpmyadmin update [SOLVED]

Dont work for me either...

Offline

#12 2009-10-07 19:23:46

oliver
Member
Registered: 2007-12-12
Posts: 411

Re: phpmyadmin update [SOLVED]

I just needed to delete the .htaccess file and add /usr/share/webapps to my open_basedir in php.ini (and restart apache) to get the phpmyadmin login screen to appear.  Before deleting the .htaccess I got a 403 and before appending the open_basedir I got the plain white screen

Offline

#13 2009-10-07 19:36:19

Ravenman
Member
Registered: 2009-07-03
Posts: 222

Re: phpmyadmin update [SOLVED]

oliver wrote:

I just needed to delete the .htaccess file and add /usr/share/webapps to my open_basedir in php.ini (and restart apache) to get the phpmyadmin login screen to appear.  Before deleting the .htaccess I got a 403 and before appending the open_basedir I got the plain white screen

I did delete the .htaccess file into /usr/share/webapps/phpmyadmin and /etc/webapps/phpmyadmin and I did restart apache ... and when I get try access the phpMyAdmin webpage, the browser shows one error 404. sad

Offline

#14 2009-10-07 19:37:06

ajb
Member
From: Poland
Registered: 2008-02-06
Posts: 31

Re: phpmyadmin update [SOLVED]

Steps i've made:

rm -r /srv/httpd/phpMyAdmin
cp /etc/webapps/phpmyadmin/apache.example.conf /etc/httpd/conf/extra/phpmyadmin.conf
echo "\nInclude conf/extra/phpmyadmin.conf" >> /etc/httpd/conf/httpd.conf

and finally comment out "deny from all" in /etc/webapps/phpmyadmin (with "#" in front of line).
I've also changed alias to capital letters, as they were. (WARNING new standard address is http://localhost/phpmyadmin/ )
At the end /etc/rc.d/httpd restart
and everything have gone great

EDIT:
Yes... also i've added /usr/share/webapps and /etc/webapps to my open_basedir in /etc/php/php.ini

Last edited by ajb (2009-10-07 20:05:45)

Offline

#15 2009-10-07 19:43:59

oliver
Member
Registered: 2007-12-12
Posts: 411

Re: phpmyadmin update [SOLVED]

Ravenman wrote:

I did delete the .htaccess file into /usr/share/webapps/phpmyadmin and /etc/webapps/phpmyadmin and I did restart apache ... and when I get try access the phpMyAdmin webpage, the browser shows one error 404. sad

Did you add the alias stuff into your httpd.conf file?

what does /var/log/httpd/error_log say when you hit refresh on the 404?

Last edited by oliver (2009-10-07 19:45:04)

Offline

#16 2009-10-07 19:47:25

Ravenman
Member
Registered: 2009-07-03
Posts: 222

Re: phpmyadmin update [SOLVED]

ajb wrote:

Steps i've made:

rm -r /srv/httpd/phpMyAdmin
cp /etc/webapps/phpmyadmin/apache.example.conf /etc/httpd/conf/extra/phpmyadmin.conf
echo "\nInclude conf/extra/phpmyadmin.conf" >> /etc/httpd/conf/httpd.conf

and finally comment out "deny from all" in /etc/webapps/phpmyadmin (with "#" in front of line).
I've also changed alias to capital letters, as they were. (WARNING new standard address is http://localhost/phpmyadmin/ )
At the end /etc/rc.d/httpd restart
and everything have gone great

Yes, it worked for me! cool

Thank you very much, AJB.

Csergec, you can label this post as solved. wink

Last edited by Ravenman (2009-10-07 19:48:13)

Offline

#17 2009-10-07 19:51:54

toffyrn
Member
Registered: 2008-10-07
Posts: 221

Re: phpmyadmin update [SOLVED]

Ok fixed now... I had a messy config with http-auth (paranoid so i try to avoid brute force attempts tongue )

this works in httpd-phpmyadmin.conf

Alias /phpMyAdmin/ "/usr/share/webapps/phpMyAdmin/"
<Directory "/usr/share/webapps/phpMyAdmin">
        AllowOverride All
        Options FollowSymlinks

        order allow,deny
        allow from all

        AuthUserFile /etc/httpd/conf/.htpasswd
        AuthName "phpmyadmin"
        AuthType Basic
        Require valid-user

</Directory>

and adding directory to open_basedir and delete .htaccess file.

What i was missing was the allow from all part...
[edit]It was alredy there before i removed it, didnt really notice it... My wrong...[/edit]

Last edited by toffyrn (2009-10-07 20:28:20)

Offline

#18 2009-10-07 20:06:51

csergec
Member
Registered: 2009-09-29
Posts: 62

Re: phpmyadmin update [SOLVED]

Hi ajb

I did everything you did except commenting out "deny from all" in /etc/webapps/phpmyadmin.
I have not this /etc/webapps/phpmyadmin file.
Can you post it here?
BTW int /etc/webapps/phpmyadmin/apache.example.conf there is "allow from all".

Serge

Offline

#19 2009-10-07 20:59:23

csergec
Member
Registered: 2009-09-29
Posts: 62

Re: phpmyadmin update [SOLVED]

Hi

Finally I resolved my problem

As I use apache for the first time outside /srv/http , I had a look at the errors and I got:

Wed Oct 07 22:42:10 2009] [error] [client 172.16.21.121] Directory index forbidden by Options directive: /usr/share/webapps/phpMyAdmin/

I checked my httpd.conf file and I noticed that I had:

#
# DirectoryIndex: sets the file that Apache will serve if a directory
# is requested.
#
<IfModule dir_module>
    DirectoryIndex index.html 
</IfModule>

So I added index.php ( phpMyAdmin is using it to open up ) and now it works...
So now I can add SOLVED

Serge

Offline

#20 2009-10-08 02:38:49

julio
Member
From: São Carlos/SP, Brazil
Registered: 2009-06-10
Posts: 9
Website

Re: phpmyadmin update [SOLVED]

OMG! It works when I use the /index.php

http://localhost/phpMyAdmin/index.php

Thanks guys!


smile

Offline

#21 2009-10-08 20:31:58

cemsbr
Member
From: Brazil
Registered: 2008-05-03
Posts: 95
Website

Re: phpmyadmin update [SOLVED]

julio wrote:

OMG! It works when I use the /index.php

http://localhost/phpMyAdmin/index.php

Thanks guys!

If you want to have http://localhost/phpmyadmin working (without trailing slash), change

Alias /phpmyadmin/ "/usr/share/webapps/phpMyAdmin/"

to

Alias /phpmyadmin "/usr/share/webapps/phpMyAdmin"

Offline

#22 2009-10-11 02:15:21

yvonney
Member
Registered: 2008-06-11
Posts: 671

Re: phpmyadmin update [SOLVED]

UPDATE COMMMENT: I just commented out the:
# Include conf/extra/phpmyadmin.conf     in  htttpd.conf
which got the icons back in the version of phpmyadimh I downloaded and put in /srv/http (see below)

and I decided to comment out the line in php.ini that starts with:
# open_basedir = 

after reading what it does. I had added the webapps folder to it as mentioned in this thread.

---- earlier written is below ------
after doing all the above, though without the benefit of enough understanding I downloaded phpMyAdmin, then renamed folder and put it in  /srv/http    and now can access phpmyadmin with:

localhost/phpmyadmin


though seems that most of the icons aren't shwoing properly.
Anyways, still working on it. Thanks for great tips.

QUESTION: I'm guessing parts of the wiki for php, mysql lamp and phpmyadmin are a bit off... ?
So, one big question is:

http://wiki.archlinux.org/index.php/PhpMyAdmin


would I try the sample   'config.inc.php'   and put THAT in  /etc/webapps/phpmyadmin ??

Or, edit the one that comes with /etc/webapps/phpmyadmin

I think the install one in /etc/webapps is lacking some variables.

The one that the installer puts there has the lines under:
/* User for advanced features */

would I put my user and password there?

Last edited by yvonney (2009-10-11 02:48:17)

Offline

#23 2009-10-11 14:20:48

julio
Member
From: São Carlos/SP, Brazil
Registered: 2009-06-10
Posts: 9
Website

Re: phpmyadmin update [SOLVED]

cemsbr wrote:

If you want to have http://localhost/phpmyadmin working (without trailing slash), change

Alias /phpmyadmin/ "/usr/share/webapps/phpMyAdmin/"

to

Alias /phpmyadmin "/usr/share/webapps/phpMyAdmin"

Thank you. Much better this way


smile

Offline

#24 2009-12-13 14:18:06

mauz
Member
From: Medellín, Antioquia, COLOMBIA.
Registered: 2005-02-19
Posts: 31
Website

Re: phpmyadmin update [SOLVED]

I have Lighttpd and i cant get phpmyadmin work.
i get a 404 - Not Found error too big in my screen!

i have made:

in /etc/lighttpd/lighttpd.conf :

alias.url = ("/phpmyadmin" => "/usr/share/webapps/phpMyAdmin/")

in /etc/webapps/phpmyadmin/config.inc.php:


$cfg['Servers'][$i]['host'] = 'maohost';

I tried to copy all config to analog ligthttpd confif files, and y comment de deny all en .htaccess.

mi php config is like this:

open_basedir = /srv/http/:/home/:/tmp/:/usr/share/pear/:/usr/share/webappps/:/etc/webapps

If some one have phpmyadmin working over lighttpd please give me a hand.!!!

log says:


2009-12-13 04:07:10: (mod_fastcgi.c.2698) FastCGI-stderr: PHP Warning:  require_once(): open_basedir restriction in effect. File(/usr/share/webapps/phpMyAdmin/index.php on line 35

PHP Warning:  require_once(/usr/share/webapps/phpMyAdmin/libraries/common.inc.php): failed to open stream: Operation not permitted in /usr/share/webapps/phpMyAdmin/index.php on line 35

PHP Fatal error:  require_once(): Failed opening required './libraries/common.inc.php' (include_path='.:/usr/share/pear') in /usr/share/webapps/phpMyAdmin/index.php

At last i have add all folders of Phpmyadmin to user http and group http to see if something happen...

Last edited by mauz (2009-12-13 14:31:39)

Offline

#25 2009-12-13 14:38:07

mauz
Member
From: Medellín, Antioquia, COLOMBIA.
Registered: 2005-02-19
Posts: 31
Website

Re: phpmyadmin update [SOLVED]

O MY B F GOD.

The mistake was

/usr/share/webappps/

i just had to remove a "d" in /webappps/

tongue


now the problem is:

Cannot load mcrypt extension. Please check your PHP configuration.

but i had remove the ; in mcrypt of my php config file



in /var/log/lighttpd


2009-12-13 09:36:22: (mod_fastcgi.c.2698) FastCGI-stderr: PHP Fatal error:  session_start(): Failed to initialize storage module: files (path: ) in /usr/share/webapps/phpMyAdmin/libraries/session.inc.php on line 75

i just add #pacman -S php-mcrypt to console and the things works nice as shhhhiii

Last edited by mauz (2009-12-13 15:09:15)

Offline

Board footer

Powered by FluxBB