You are not logged in.

#1 2011-02-28 15:13:10

joe of loath
Member
Registered: 2010-09-28
Posts: 18

USB devices cause 100% CPU usage

Hi there

I'm using Arch x86_64 on my Dell laptop. Everything works fine, except the USB. Since roughly the 18th of February, when I plug in some USB devices (USB memory sticks, my wireless mouse, but not a webcam or wireless keyboard+mouse combo), the device isn't recognised, and CPU usage on one core hits 100%, caused by a program called kworker.

Has anyone experienced this? I've done some googling, and it seems to be kernel related, but can't seem to find a fix.

Thanks in advance,
Joe

Offline

#2 2011-02-28 16:35:47

davidm
Member
Registered: 2009-04-25
Posts: 338

Re: USB devices cause 100% CPU usage

Hello. Unfortunately I have no workarounds but I wanted to make sure that you saw these if you haven't already:

http://www.mail-archive.com/acpi-bugzil … 33282.html
https://bugzilla.kernel.org/show_bug.cgi?id=29722

It looks like it might possibly be related and could be a kernel bug as you suspect.  Does the same happen when you do a clean reboot? They have suggested some workarounds and  you may wish to try them and join in on the bug report to help fix it if you think it is related.

Last edited by davidm (2011-02-28 16:38:20)

Offline

#3 2011-02-28 16:56:54

joe of loath
Member
Registered: 2010-09-28
Posts: 18

Re: USB devices cause 100% CPU usage

Hmmm, I might roll back a kernel and, assuming it works, just use that for the time being. Does Arch keep old kernels around, like other distributions do? I know Ubuntu lists every single installed Kernel in grub.

Offline

#4 2011-02-28 17:16:51

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,071

Re: USB devices cause 100% CPU usage

nope. but if you haven't cleared your pacman cache, you will probably find it under there.


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#5 2011-02-28 17:17:31

SpleenThief
Member
Registered: 2011-02-28
Posts: 16

Re: USB devices cause 100% CPU usage

I'm interested in this too. How could i do it if I have cleared it?

Offline

#6 2011-02-28 17:18:19

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,071

Re: USB devices cause 100% CPU usage

look into Arch Rollback Machine.


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#7 2011-02-28 19:07:15

joe of loath
Member
Registered: 2010-09-28
Posts: 18

Re: USB devices cause 100% CPU usage

Installing the LTS kernel, should tell me if it's a kernel problem or not.

Offline

#8 2011-02-28 22:32:46

joe of loath
Member
Registered: 2010-09-28
Posts: 18

Re: USB devices cause 100% CPU usage

The lts kernel fixes it, but I don't see any of my desktop environments when using it lol (Slim logs in, then I just get a black screen with a cursor. Very strange).

Oh well. I guess it won't be long until 2.6.38 is out, I'll just wait for that.

Last edited by joe of loath (2011-02-28 22:33:16)

Offline

#9 2011-03-02 03:34:53

SpleenThief
Member
Registered: 2011-02-28
Posts: 16

Re: USB devices cause 100% CPU usage

Are you using laptop mode tools? To copy paste from my thread (I was having a similar issue, without the kworker):

My problem was having USB autosuspend disabled in laptop-mode-tools. I fixed this by changing "CONTROL_USB_AUTOSUSPEND" in /etc/laptop-mode/conf.d/usb-autosuspend.conf to 1 and having a long "AUTOSUSPEND_TIMEOUT".

https://bbs.archlinux.org/viewtopic.php?pid=897712

Last edited by SpleenThief (2011-03-02 03:35:21)

Offline

#10 2011-03-02 10:25:21

joe of loath
Member
Registered: 2010-09-28
Posts: 18

Re: USB devices cause 100% CPU usage

I am, but I disabled USB autosuspend and it still happens.

Offline

#11 2011-03-02 11:15:07

Ultraman
Member
Registered: 2009-12-24
Posts: 242

Re: USB devices cause 100% CPU usage

Problems with kworker have been more common recently, I suffer from it as well and can also relate it to USB and possibly power saving.
I'm not saying I really have the solution for this but I did make some progress on my end which did fix my issues so far.

See my posts at: https://bbs.archlinux.org/viewtopic.php … 13#p898113
And my topic: uhci_hcd spamming my logs

Disabling USB auto-suspend did not fix it for me either. Unloading the uhci_hcd and ehci_hcd do stop kworker thrashing. (use # modprobe -r <module> to do so)

I then came across a bug report that talked about PCIE ASPM (PCI Express Power Savings), and I know that this wasn't enabled by default on older kernel but was so on more recent ones (.36 i believe, but check the configs for that to be sure).
To disable these power savings, add "pcie_ports=compat" to your bootline in GRUB config, GRUB2 in my case. In case you use GRUB Legacy the file is /boot/grub/menu.lst iirc.
Example of what my line looks like in /boot/grub/grub.cfg:

linux /vmlinuz26 root=/dev/disk/by-uuid/[..] rootfstype=ext4 resume=/dev/disk/by-uuid/[..] ro pcie_ports=compat

See if that helps.

Offline

#12 2011-03-02 15:16:15

VitaminJ
Member
Registered: 2009-10-19
Posts: 26

Re: USB devices cause 100% CPU usage

I have the same problem as of a few days

Linux D830 2.6.37-ARCH #1 SMP PREEMPT Fri Feb 18 18:32:16 CET 2011 x86_64 Intel(R) Core(TM)2 Duo CPU T7700 @ 2.40GHz GenuineIntel GNU/Linux

Running laptop-mode-tools, with CONTROL_USB_AUTOSUSPEND="auto" in /etc/laptop-mode-tools/conf.d/usb-autosuspend.conf. I left this as is and added the PCIE ASPM kernel argument and this seems to have resolved...

FOLLOWUP
Updated to kernel kernel26 2.6.37.2-1, now it's really broken!

Here, the mouse is unplugged, and I proceed to unload all USB modules

[root@D830 jay]# modprobe -r usblp btusb uhci_hcd ehci_hcd
[root@D830 jay]# modprobe -r usbcore
[root@D830 jay]# modprobe usbcore
[root@D830 jay]# modprobe ehci_hcd
[root@D830 jay]# modprobe uhci_hcd

Now I set up monitoring for events, and plug in the mouse. The result is nothing.

[root@D830 jay]# udevadm  monitor
monitor will print the received events for:
UDEV - the event which udev sends out after rule processing
KERNEL - the kernel uevent

^C

Leaving the mouse plugged in, I unload USB again...then unplug the mouse, and I get output.

[root@D830 jay]# modprobe -r usblp btusb uhci_hcd ehci_hcd
[root@D830 jay]# modprobe -r usbcore
[root@D830 jay]# modprobe usbcore
[root@D830 jay]# modprobe ehci_hcd
[root@D830 jay]# modprobe uhci_hcd
[root@D830 jay]# udevadm  monitor
monitor will print the received events for:
UDEV - the event which udev sends out after rule processing
KERNEL - the kernel uevent

KERNEL[1299126891.159733] remove   /devices/pci0000:00/0000:00:1d.0/usb5/5-2/5-2:1.0/usb/lp0 (usb)
KERNEL[1299126891.159808] remove   /class/usb (class)
KERNEL[1299126891.159864] remove   /devices/pci0000:00/0000:00:1d.0/usb5/5-2/5-2:1.0 (usb)
KERNEL[1299126891.159911] remove   /devices/pci0000:00/0000:00:1d.0/usb5/5-2/5-2:1.1 (usb)
KERNEL[1299126891.160146] remove   /devices/pci0000:00/0000:00:1d.0/usb5/5-2 (usb)
UDEV  [1299126891.160672] remove   /devices/pci0000:00/0000:00:1d.0/usb5/5-2/5-2:1.0/usb/lp0 (usb)
UDEV  [1299126891.161305] remove   /class/usb (class)
UDEV  [1299126891.161360] remove   /devices/pci0000:00/0000:00:1d.0/usb5/5-2/5-2:1.0 (usb)
UDEV  [1299126891.161860] remove   /devices/pci0000:00/0000:00:1d.0/usb5/5-2/5-2:1.1 (usb)
UDEV  [1299126891.165562] remove   /devices/pci0000:00/0000:00:1d.0/usb5/5-2 (usb)

I have /etc/laptop-mode/conf.d/usb-autosuspend enabled on AC and batt, with a delay of 15 seconds AND the kernel pci-ports=compat argument in /boot/grub/menu.lst

Last edited by VitaminJ (2011-03-03 04:45:35)

Offline

#13 2011-03-04 12:22:19

Ultraman
Member
Registered: 2009-12-24
Posts: 242

Re: USB devices cause 100% CPU usage

I still have laptop-mode-tools and USB auto-suspend disabled with 2.6.37.2 and no issues.
When I plug in a USB stick, I see my CPU load go sky high and it drops back down after 2 a 3 seconds.

Still my battery life is not near what it used to be before this "bug". But at least I'm back to a idle CPU of 9% instead of 70% on one core @ max freq.
Powertop still shows kworker creating interrupts inbetween chromium and ath9k and kernel load balancing, so still too much imo.
Normally I could get about 8W of power consumption, now I'm lucky if get below 9.5W.

Last edited by Ultraman (2011-03-04 14:36:05)

Offline

#14 2011-03-04 12:25:24

joe of loath
Member
Registered: 2010-09-28
Posts: 18

Re: USB devices cause 100% CPU usage

Probably a conflict somewhere, then. I'll just sit it out I guess. I'm still dual booting my old installation, it's slow but works.

Off topic, what hardware are you running to only draw 8w? I thought 12w on a good day was excellent tongue

Offline

#15 2011-03-04 13:19:04

VitaminJ
Member
Registered: 2009-10-19
Posts: 26

Re: USB devices cause 100% CPU usage

Try removing laptop-mode from your daemons in /etc/rc.conf, and reboot.

Offline

#16 2011-10-31 13:14:27

joe of loath
Member
Registered: 2010-09-28
Posts: 18

Re: USB devices cause 100% CPU usage

Still experiencing this issue - I've found a fix, but it's messy. Every time a USB device is plugged in, I have to reload the modules uhci_hcd and ehci_hcd. The device then works perfectly.

Anyone?

Offline

Board footer

Powered by FluxBB