You are not logged in.

#1 2012-10-01 14:38:15

bel3atar
Member
Registered: 2012-07-02
Posts: 23

Disabling systemd-journal

Hello,

I am running Arch on a low spec machine, and I'd like to get rid of system logging.
I tried systemctl disable systemd-journald but the service comes back after reboot.

Have a good day.

Offline

#2 2012-10-01 14:40:48

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Disabling systemd-journal

mask it, though I am unsure that would be wise.

Offline

#3 2012-10-01 16:11:20

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: Disabling systemd-journal

WonderWoofy wrote:

mask it, though I am unsure that would be wise.

So am I. A wiser approach seems to be editing '/etc/journald.conf' instead and changing the most performance critical values appropriately. 'man journald.conf' should help decide what to tweak.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#4 2012-10-01 19:11:37

bel3atar
Member
Registered: 2012-07-02
Posts: 23

Re: Disabling systemd-journal

There seems to be no way of disabling journald through journald.conf
Setting Storage=none won't: the service keeps running, it just doesn't store anything on disk.
Maybe future versions of systemD would implement a way to disable the journalling functionality?

Offline

#5 2012-10-01 19:17:42

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: Disabling systemd-journal

bel3atar wrote:

There seems to be no way of disabling journald through journald.conf

You can't disable journald as far as I can tell. I mentioned using /etc/systemd/journald.conf to optimize the service instead...


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#6 2012-10-01 19:19:15

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,133

Re: Disabling systemd-journal

storage=none will at least stop it from writing to the disk, but I don't know of a way to keep it from running. This is one of the things people complain about with systemd. I find it to be a great init system, but I'll never understand why they need to integrate journald, longind, udev, etc all into one package.

Last edited by Scimmia (2012-10-01 19:19:26)

Offline

#7 2012-10-01 22:05:23

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Disabling systemd-journal

Did you try masking it?  If so, I am very curious what happened...

Offline

#8 2012-10-01 22:18:09

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,133

Re: Disabling systemd-journal

I think I'm going to try it, brb.

Offline

#9 2012-10-01 22:31:12

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,133

Re: Disabling systemd-journal

Yeah, don't do that, atleast not by itself. Masking systemd-journald causes all kinds of dependency failures and drops you at an emergency prompt.

Offline

#10 2012-10-01 22:32:07

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Disabling systemd-journal

Hey, thanks for testing it, I figured something like that would happen.

Offline

#11 2012-11-05 15:50:22

anrxc
Member
From: Croatia
Registered: 2008-03-22
Posts: 834
Website

Re: Disabling systemd-journal

Interesting, there aren't many results on search engines about disabling the Journald. Perhaps there will be
more when other distributions adopt Systemd.

That feature is very important for any network heavily relying on the Syslog; from security auditing, to gathering
business intelligence data, or simply monitoring for MCE/RAID/RAM failures. Because now you have this brand
new software forcing it self between Rsyslog or Syslog-NG and playing a proxy and if it crashes[1] there's nothing
you can do. It's also unknown how it will handle millions of messages passing through it (ie. web server page
views).

According to this[2] mailing list post it is on the TODO list, but desktops not servers seem to be the priority
in everything.

Edit: the new Journald corruption thread[3] is interesting in the context that Journald is still too new.

1. http://lists.freedesktop.org/archives/s … 04386.html
2. http://permalink.gmane.org/gmane.comp.s … devel/4693
3. https://bbs.archlinux.org/viewtopic.php?id=150442

Last edited by anrxc (2012-11-06 17:35:14)


You need to install an RTFM interface.

Offline

#12 2012-11-06 08:05:53

xamaco
Member
From: Corsica, France
Registered: 2010-04-05
Posts: 87

Re: Disabling systemd-journal

Storage=none keeps journald running. From journald.conf man page :

none turns off all storage, all log data received will be
           dropped. Forwarding to other targets, such as the console, the
           kernel log buffer or a syslog daemon will still work however.

I use it on one machine in conjunction with syslog-ng: It allows me to keep the old logs and a few scripts I wrote to do some checking running.
The closest thing to disable would probably be to use 'volatile'.

Offline

#13 2013-10-23 16:12:03

AskApache
Member
Registered: 2009-10-18
Posts: 16
Website

Re: Disabling systemd-journal

I use syslog-ng and also find the journald to be annoying.  Hey that's what you get with Arch, the cutting edge.

What I do is what bohoomil suggests and edit the /etc/systemd/journald.conf..  here are my settings, which don't actually disable journald from logging, since sometimes you do want that.

[Journal]                                                                                                                                                                                                                                                                                                                       
Storage=persistent
Seal=no
SystemMaxUse=50M
RuntimeMaxUse=50M
ForwardToSyslog=yes

Offline

Board footer

Powered by FluxBB