You are not logged in.

#26 2011-11-14 12:54:24

David Batson
Member
Registered: 2011-10-13
Posts: 640

Re: [solved] video tearing on intel sandy bridge

AFAIK, the Gnome 3 Shell (the default desktop) will not work with Compiz.  Haven't tried watching videos from the Gnome 3 Shell desktop yet.  In Fedora 15 I installed Gnome 3 and Compiz, and at the login screen there is an option to login to Gnome Classic with Compiz.  I will install Fedora 16 when I get home and have a landline to download it from (I am out of town atm).  It seems that Compiz is still an option with Gnome 3 in Fedora 16.  Probably works in Arch.

http://comments.gmane.org/gmane.linux.r … ters/94678

Offline

#27 2011-11-15 10:33:57

xwhatsit
Member
Registered: 2011-03-15
Posts: 13

Re: [solved] video tearing on intel sandy bridge

fiinix wrote:

i really don't wanna just give up on this, but i won't be able to resume searching for a solution as of in a few days. sorry guys.

do i see this right, that no one with sandy bridge graphics (hd 3000) has video playack without tearing except people using compiz?

I, too, have video tearing.

I have an X220 with an i5 2410M (HD3000). I run awesome as my window manager, not GNOME 3, but when I use dcompmgr or xcompmgr (i.e. a compositing manager) I have very noticeable tearing, even using mplayer's vaapi output (or even gl2 output).

If I kill the dcompmgr process, using gl2 or vaapi output there is no tearing. There is still tearing using xv output (from mplayer, again).

My girlfriend has an X121e, which has an i3 2357M (also HD3000, just lower speed clock). She uses GNOME 3. Now in GNOME 3 there appears to be no way to turn off compositing (unless you switch to the `classic' desktop -- she much prefers the new GNOME 3 desktop, though, so that is no solution). So in GNOME 3 there is tearing all the time.

If this isn't fixed in the near future I may have to write a little script that is launched from Nautilus and starts up a separate X session (only X, no window manager, and no compositing manager) that shows mplayer in a fullscreen for a given video file. Would have to do something about the media keys though so that's a pain.

To sum up, the key seems to be compositing. If you're using it, videos tear. Unless your compositing manager has a vsync option (like Compiz). Dcompmgr/xcompmgr don't, neither does GNOME 3's compositing manager (Mutter? Clutter? Haven't looked at exactly what does the compositing).

Offline

#28 2011-11-15 11:14:58

jackgu1988
Member
Registered: 2010-11-16
Posts: 39

Re: [solved] video tearing on intel sandy bridge

@xwhatsit even when I disable compositing on KDE, nothing changes. Not solving my issue at all

Offline

#29 2011-11-15 13:24:12

steve___
Member
Registered: 2008-02-24
Posts: 439

Re: [solved] video tearing on intel sandy bridge

@jackgu1988 - Are you using gl2 or vaapi output or xv?

Offline

#30 2011-11-18 12:08:30

David Batson
Member
Registered: 2011-10-13
Posts: 640

Re: [solved] video tearing on intel sandy bridge

I don't know if this would be a solution when using the Gnome 3 shell or not.

https://bbs.archlinux.org/viewtopic.php … 5#p1017705

Offline

#31 2011-11-18 16:15:24

sitquietly
Member
From: Moscow, Tennessee
Registered: 2010-07-12
Posts: 216

Re: [solved] video tearing on intel sandy bridge

fiinix wrote:

...new laptop with nice hardware ... annoying tearing each time some movement happens in the picture ... can't be slow hardware ...
dell vostro v131, core i3-2330 (2.2ghz), sandy bridge, gma hd 3000 graphics, 4gb ddr3, ext4 filesystem

is it working without tears for you?


I've been rechecking my SB system for tearing since adding the vaapi driver and enabling hardware accel in vlc. I just can't find any tearing anymore; in the past, without vaapi, I had seen barely perceptible tearing in a few movies, it occurred only once in several minutes.

I AM running compositing under KDE. No tearing.

BUT my hardware is different: it's the Intel dh67gd micro-itx board (with 16 GB of memory). I heard that Intel put some fix on this board for the 24fps problem, that's why I bought this specific one. With latest video drivers everything seems to be working perfectly for me under KDE --- I just thought that folks reading this thread could use a specific hardware recommendation for future desktop builds.

Offline

#32 2011-11-19 02:24:39

David Batson
Member
Registered: 2011-10-13
Posts: 640

Re: [solved] video tearing on intel sandy bridge

David Batson wrote:

I don't know if this would be a solution when using the Gnome 3 shell or not.

https://bbs.archlinux.org/viewtopic.php … 5#p1017705

Seems to work for me in Fedora 15 Gnome (3) without compiz running.  Only the first line seemed to make a difference on my laptop.

Try putting into /etc/environment the following and reboot:

CLUTTER_PAINT=disable-clipped-redraws:disable-culling

I Googled the above line and found there is a bug report on Fedora Bugzilla (F16 Gnome) where the above code fixes some issues.
https://bugzilla.redhat.com/show_bug.cgi?id=720605

More interesting is what is on Gnome Bugzilla: https://bugzilla.gnome.org/show_bug.cgi?id=657071#c2

> CLUTTER_PAINT=disable-clipped-redraws:disable-culling

Furthermore I found that running with this env var makes gnome-shell vsync
properly while it doesn't without it.

Offline

#33 2011-12-15 01:35:12

fiinix
Member
Registered: 2009-12-07
Posts: 75

Re: [solved] video tearing on intel sandy bridge

Wow, what a pleasant surprise! The problem is solved for me following post #32. Thank you David Batson!
Meanwhile I had the Dell Vostro go back and got me a new one - again with Sandy Bridge. Very nice not to have that tearing anymore smile

Offline

#34 2011-12-16 16:07:00

jackgu1988
Member
Registered: 2010-11-16
Posts: 39

Re: [solved] video tearing on intel sandy bridge

@David Batson for KDE I needed to have enabled vsync as well and also add CLUTTER_VBLANK=True to the /etc/environment file (as the thread you posted says). I haven't tried it in it in a movie where the camera moves really fast, but seems to have fixed the problem so far. Thanks!!!

Offline

#35 2011-12-16 17:57:45

xwhatsit
Member
Registered: 2011-03-15
Posts: 13

Re: [solved] video tearing on intel sandy bridge

Are you sure you need the CLUTTER_VBLANK line in KDE, jackgu1988? Clutter is only used for GNOME, isn't it? KDE has its own compositor and WM etc.

Offline

#36 2011-12-20 13:52:21

jackgu1988
Member
Registered: 2010-11-16
Posts: 39

Re: [solved] video tearing on intel sandy bridge

@xwhatsit maybe it was just vsync. I did both at the same time, so I can't tell if just one of them was required.

Offline

#37 2012-01-03 03:56:35

darthpenguin
Member
Registered: 2011-09-16
Posts: 77

Re: [solved] video tearing on intel sandy bridge

Hey Guys

the solution in post 32

CLUTTER_PAINT=disable-clipped-redraws:disable-culling

worked for me.

but when I turn monitor to portrait I get tearing again.

Offline

#38 2012-01-18 01:28:07

jarda-wien
Member
Registered: 2008-03-13
Posts: 104

Re: [solved] video tearing on intel sandy bridge

CLUTTER_PAINT=disable-clipped-redraws:disable-culling

worked for me in the past, but after a recent kernel upgrade, I get the tearing problem again.
I now have

CLUTTER_PAINT=disable-clipped-redraws:disable-culling
CLUTTER_VBLANK=True

in /etc/environment and I do experience video tearing all the time...

Is there another way to solve this?

Offline

#39 2012-01-18 17:08:07

David Batson
Member
Registered: 2011-10-13
Posts: 640

Re: [solved] video tearing on intel sandy bridge

VLC works fine here in Arch xfce with compiz - fully up to date.  VLC works fine in Fedora 16 gnome - fully up to date.  Don't know what to say.  Have you tried rebooting?

Last edited by David Batson (2012-01-18 17:08:45)

Offline

#40 2012-01-18 17:17:32

Gusar
Member
Registered: 2009-08-25
Posts: 3,466

Re: [solved] video tearing on intel sandy bridge

You guys are probably hitting this bug: https://bugs.freedesktop.org/show_bug.cgi?id=37686 You can try various magic incantations, but you may not have any luck until that bug is fixed.

Online

#41 2012-01-18 18:03:47

David Batson
Member
Registered: 2011-10-13
Posts: 640

Re: [solved] video tearing on intel sandy bridge

I did have a temporary problem with an ffmpeg update not too long ago causing this problem.  The problem only seemed to last a day or so for me.

https://bbs.archlinux.org/viewtopic.php?id=133338

Offline

#42 2012-01-31 23:28:59

jarda-wien
Member
Registered: 2008-03-13
Posts: 104

Re: [solved] video tearing on intel sandy bridge

I am not sure what was the main cause of the problem. Maybe ffmpeg, maybe something else.

Someone suggested using vaapi, so I downloaded mplayer with vaapi support and all the libraries. It actually worked, bud subtitle rendering was not good and flashplayer videos were still tearing.

Anyway, I am using xf86-video-intel-git from AUR and the issue is gone.

Edit: today I got the tearing again, even with the git driver. I am back to normal drivers and vaapi. The subtitle rendering seems fine. It must have have had something to do with the video itself.

Last edited by jarda-wien (2012-02-01 20:43:45)

Offline

#43 2012-12-22 12:15:39

postadelmaga
Member
Registered: 2012-12-22
Posts: 2

Re: [solved] video tearing on intel sandy bridge

Did some test here and I thinks I find out the origin of the issue ( comment #19 gave me the right hint, about overlay ):

Basically if you:
- disable composite ( sorry till now I cannot find a better solution )
AND
- [VLC] deselect this option: Video -> Display -> Accelerated video output (Overlay)
OR
- [VLC] select this video output: Video -> Output -> OpenGL GLX

You will not have any Tearing smile

p.s.
I'm on ubuntu 12.10 32bit, hd3000 and Xfce - ( I have tested also without any window manager X+VLC and I had same results )
It looks last vlc support VA-API

I subscribed here only to post this solution I hope it helps

Give a look also here for updates: https://bugs.launchpad.net/ubuntu/+sour … bug/755841

Last edited by postadelmaga (2012-12-22 12:29:29)

Offline

#44 2013-03-03 01:00:39

v43
Member
Registered: 2011-02-03
Posts: 140

Re: [solved] video tearing on intel sandy bridge

I'm running KDE and VLC on a sandy bridge HD3000 (i5 2500K).

it looks like setting the desktop composition from OpenGL to Xrender fixed the problem.

also, VLC is set to use GPU acceleration and OpenGL output.

Offline

#45 2013-03-30 18:09:18

kellerman
Member
From: Latvia
Registered: 2011-07-20
Posts: 101

Re: [solved] video tearing on intel sandy bridge

Under XFCE with intel sandy bridge CPU and graphics, I can say that nothing from above helped.
Check out this thread and last posts. This works very well.
https://bbs.archlinux.org/viewtopic.php?id=135042

Last edited by kellerman (2013-03-30 18:09:41)

Offline

#46 2014-02-02 20:15:12

ssn
Member
Registered: 2014-02-02
Posts: 1

Re: [solved] video tearing on intel sandy bridge

I had the same problem on HD 3000.
The tearing was not only in video: I experienced it during dragging windows and using smooth scrolling in Firefox.

This solution helped: https://wiki.archlinux.org/index.php/In … free_video

Last edited by ssn (2014-02-02 20:18:08)

Offline

#47 2014-02-02 20:21:42

karol
Archivist
Registered: 2009-05-06
Posts: 25,431

Re: [solved] video tearing on intel sandy bridge

Instead of resurrecting an old thread, read a recent one: https://bbs.archlinux.org/viewtopic.php?id=176576

Offline

Board footer

Powered by FluxBB